Keel Blisters

posting disabled

Moderator: forumadmin

Postby Guest » Mon Apr 28, 2003 7:28 pm

Last weekend I discovered blisters while wet-sanding the keel in preparation for a race this weekend. I have been told that this most likely is being caused by the epoxy barrier coat failing. The barrier coat is about three years old. Some questions for the experts:

- Is this a common occurence?
- During repair, how can this problem be avoided in the future?
- Does the type of epoxy used affect the longevity of the barrier coat integrity?

Any help would be much appreciated. Thanks!

Chip Vollers
#257 "Gizmo"
Guest
 

Postby Guest » Tue Apr 29, 2003 7:21 pm

Chip,

My bottom has an Interlux 2000 barrier coat that has been working fine for 7 years. It was professionally applied. I believe that a properly applied barrier coat will last indefinitely - otherwise, why do it?

Your boat name is Seattle? If that implies that you store the boat in freezing climate, your keel blistering may be caused by water that migrated into your keel from the sump and then froze. That type of damage is usually found in the top third of the keel and typically looks more like splits than blisters.

Springtime is not the time to mention it, but in the Northeast we put propelyne glycol anti-freeze in the sump for the winter.
Guest
 

Postby Guest » Wed Apr 30, 2003 12:03 pm

Hi Bob,

Thanks for your comments. The boat is located in Seattle, but we rarely see freezing temperatures even in the middle of the winter (I also keep a small heater going during the winter to minimize condensation in the cabin). In fact the water temperature really doesn't change that much...it's always cold!

I'm thinking there were issues with the original barrier-coat installation done when the previous owner commissioned the boat.

Chip
Guest
 


Return to Archived Maintenance Topics

Who is online

Users browsing this forum: No registered users and 1 guest

cron